IIS Modules Installation Instructions

The Checkbox V7 installation requires several IIS modules to be installed, including:

 

- .NET Extensibility 4.6

- ASP.NET 4.6

- ISAPI Extensions

- ISAPI Filters

 

Please ensure that these modules are installed in IIS.

 

The process by which you can install the ASP.NET 4.6 module is:

 

  1. Open Server Manager.

  2. Click Add roles and features.

  3. Click Installation type. Click Role-based or feature-based installation and then click Next.

  4. On the Server Selection dialog box, click Select a server from the server pool. In the Server Pool list, select your server and then click Next.

  5. On the Server Roles dialog box select, Web Server (IIS). If you are prompted to add additional features, click Add Features and then click Next.

  6. On the Role Services dialog box, expand the Application Development node and select ASP.NET 3.5. If you are prompted to add additional features, click Add Features.

  7. Select ASP.NET 4.6 and then click Next.

  8. Leave all other default role services selected.

  9. On the Confirmation dialog box, click Install. Proceed through the Add Roles and Features Wizard. As the wizard runs, look through the list of installation items and verify that the following role services are included. These are the minimum requirements for Interaction Administrator Web Edition:
    • Common HTTP Features

      • Static Content

      • Default Document

    • Security

      • Request Filtering

    • Application Development

      • .NET Extensibility 3.5

      • .NET Extensibility 4.6

    • Performance

      • Static Content Compression

    • Management Tools

      • IIS Management Console

Note: You may see other dialog boxes appear as role services are installed. You may also be prompted for the location of the Windows 2016 Server installation media.

  1. When the wizard is complete, click Close.

To enable ASP.NET extensions:

  1. Open Server Manager.

  2. From the Tools menu, select Internet Information Services (IIS) Manager.

  3. In the Connections pane, select the local computer name.

  4. Double-click ISAPI and CGI Restrictions.

  5. In the list of ISAPI and CGI Restrictions, find the entry for ASP.NET 4.0.x (where x is the current release). Is this restriction allowed?

    • If yes, you have finished this procedure.

    • If no, right-click on ASP.NET 4.0.x and then click Allow.



Note: If you do not see ASP.NET 4.0.x in the list, then either you do not have the 4.0 Framework installed, or you do not have ASP.NET 4.0 extensions installed. To install the extensions, run aspnet_regiis.exe with the -i option from the 4.0 Framework directory. By default, this is located at C:\WINDOWS\Microsoft.NET\Framework\v4.0.30319. Then enable the extension.

 

To install the ISAPI modules, follow this guide: https://docs.microsoft.com/en-us/previous-versions/iis/6.0-sdk/ms524567(v%3Dvs.90)

 

The installation also requires the Rewrite module, which can be installed from here: https://www.iis.net/downloads/microsoft/url-rewrite

 

Once done, you should see this icon included among the IIS modules: http://www.web-site-scripts.com/knowledge-base/admin/media_store/2/AA-00470/url-rewrite-installed.png

 

Have more questions? Submit a request

0 Comments

Article is closed for comments.